Some customers are reporting issues re-assigning tasks and other functionality

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:24 MDT

Monitoring

We have implemented a fix and are monitoring the situation closely.
Posted Jun 12, 2025 - 13:56 MDT

Update

We are receiving reports of widespread internet outages impacting multiple services, such as Cloudflare and Google Cloud Platform. These outages are currently impacting Limble, so we are monitoring the situation closely.
Posted Jun 12, 2025 - 13:26 MDT

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 13:06 MDT
This incident affected: Limble CMMS Web Application.