Email disruption

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 16:29 MDT

Update

This issue has been resolved. New emails are now being sent; we're assessing previously sent emails.
Posted Sep 08, 2026 - 12:58 MDT

Update

We have identified the cause of the email issue and are working to resolve it now.
Posted Sep 08, 2026 - 09:50 MDT

Investigating

We are currently investigating an issue with outgoing emails.
Posted Sep 08, 2026 - 06:43 MDT
This incident affected: Limble CMMS Web Application.