Login page errors in Microsoft Edge

Incident Report for Limble

Resolved

The Limble application is currently operational, and we’ve verified that the application is safe and secure.

At no time during this incident were Limble systems compromised. No customer data was accessed, exposed, altered or lost as a result of the incident. Limble was incorrectly marked as unsafe by some third-party security reputation services. We've worked with those third parties to correct their classification, and all publicly available security reputation lists are currently showing Limble as safe.

If you are still experiencing problems accessing Limble, you may need to update any host-based or network-based security systems to retrieve the latest classification data.
Posted Aug 12, 2026 - 10:44 MDT

Update

The Limble application is currently operational, and we’ve verified that the application is safe and secure. We are working with a handful of third parties that have incorrectly marked the application as unsafe to update their classification.

Customers who are still seeing disruption may be impacted by local network configuration that is blocking connections to Limble. Those customers may wish to update their network security settings to specifically allow connections to app.limblecmms.com and auth.limblecmms.com.
Posted Aug 11, 2026 - 18:44 MDT

Monitoring

The main Limble application URL (app.limblecmms.com) is now working for users in Microsoft Edge. We are monitoring to ensure full resolution.
Posted Aug 11, 2026 - 14:41 MDT

Identified

We are seeing intermittent errors for some users accessing app.limblecmms.com through Microsoft Edge. We are working with the third parties that are incorrectly marking the application as unsafe.
Posted Aug 11, 2026 - 14:02 MDT

Monitoring

The Limble authentication page is working for some users now in Microsoft Edge. We are monitoring to ensure full resolution.
Posted Aug 11, 2026 - 13:36 MDT

Identified

We’re aware that some customers are seeing a phishing warning when attempting to access the Limble login page. We've investigated and confirmed that the Limble site is safe and secure, and our team is actively working to resolve the issue with third parties that are incorrectly marking the site as unsafe.

If you run into issues when using Microsoft Edge or Google Chrome, you may use the following URL to log in to Limble:

https://us-auth.limblecmms.com/
Posted Aug 11, 2026 - 12:56 MDT

Update

The issue may be affecting browsers on Windows other than Microsoft Edge, in cases where Microsoft Defender is running locally. We are still investigating the root cause.
Posted Aug 11, 2026 - 12:46 MDT

Investigating

We are currently investigating an issue that is causing errors on the Limble login page when using the Microsoft Edge browser.
Posted Aug 11, 2026 - 12:09 MDT
This incident affected: Limble CMMS Web Application and Limble CMMS Authentication Service.