Limble Failing to Load

Incident Report for Limble

Postmortem

Date: October 14, 2025

Status: Resolved

Impacted Region(s) or Services: Limble CMMS Web and Mobile Application (US Region)

Note: All times are in Universal Coordinated Time (UTC)

Summary

On October 14 at approximately 12:48 AM, customers began experiencing issues accessing Limble. While users could log in successfully, application features failed to load, displaying spinning indicators followed by error messages. Our engineering team immediately initiated our incident response plan and identified that our database connection management service had failed. The issue was resolved at 13:51 AM after engineers successfully restarted the affected service components.

Customer Impact

For approximately 1 hour, customers were unable to access or use Limble functionality in the desktop or mobile applications. Users could reach the login page but could not load any data or perform actions within the application. The service was successfully restarted, immediately restoring full functionality to all users. No customer data was lost during this incident.

Root Cause

A sudden spike in database connection requests caused our database connection pooling service to stop accepting new connections. This service acts as a gateway between the application and our database, and when it failed, users were unable to retrieve or update any information.

Our engineering team quickly isolated the issue and determined that a manual restart of the connection service was required. 

Improvements

We take service reliability seriously and have identified several improvements to prevent similar incidents:

  • Automated Health Monitoring: Have implemented additional automated health checks on this specific service to detect failures immediately and enable automatic recovery
  • Automatic Restart Capability: Will implement self-healing capabilities to this database connection service so it can automatically restart when issues are detected, consistent with our other infrastructure components
  • Enhanced Observability: Will implement improved logging and diagnostic capabilities for this service to enable faster troubleshooting

Timeline of Events

  • 10/14/2025 at 12:48 PM UTC: Issue detected
  • 1:55 PM UTC: Incident response team assembled
  • 2:05 PM UTC: Customers notified via in-app messaging
  • 2:15 PM UTC: Root cause identified
  • 2:25 PM UTC: Service restart initiated
  • 2:51 PM UTC: Full service restored and confirmed operational
  • 3:08 PM UTC: Status page updated
  • 3:19 PM UTC: Incident officially resolved; monitoring continued
Posted Oct 16, 2025 - 06:43 MDT

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 08:18 MDT

Monitoring

We've fixed the issue and are currently monitoring to ensure stability.
Posted Oct 14, 2025 - 08:08 MDT

Investigating

We are currently investigating an issue with the application failing to load.
Posted Oct 14, 2025 - 07:20 MDT
This incident affected: Limble CMMS Web Application and Limble CMMS API.