Cloudflare Service Interruption

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:21 MST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:16 MST

Update

We've identified and implemented a fix that should restore all Limble Services. We will continue to monitor.
Posted Nov 18, 2025 - 07:28 MST

Update

Cloudflare is continuing to work on the outage, and some Limble Customers are still affected. We are continuing to monitor the situation.
Posted Nov 18, 2025 - 06:22 MST

Update

Cloudflare services are not yet fully restored, but some relief has been confirmed.
Posted Nov 18, 2025 - 05:58 MST

Update

Cloudflare is beginning to see service restored, which extends to Limble services. From their status page: "We are seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts."
Posted Nov 18, 2025 - 05:34 MST

Monitoring

Cloudflare is beginning to see service restored, which extends to Limble services. From their status page: "We are seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts."
Posted Nov 18, 2025 - 05:34 MST

Update

It seems that Limble services are currently being affected by an issue with Cloudflare.
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
https://news.ycombinator.com/item?id=45963949
Posted Nov 18, 2025 - 05:26 MST

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 05:23 MST
This incident affected: Limble Fuse (Limble Fuse System) and Limble CMMS Web Application, Limble CMMS API, Limble CMMS Marketing Website, Limble CMMS Authentication Service, Limble CMMS Authentication Service Backend, Limble Search.