Limble is now loading OK in Microsoft Edge. The Limble application is currently operational, and we’ve verified that the application is safe and secure.
At no time during this incident were Limble systems compromised. No customer data was accessed, exposed, altered or lost as a result of the incident. Limble was incorrectly marked as unsafe by some third-party security reputation services. We are continuing to work with those third party services to correct Limble's classification.
Some users on local networks implementing network-based security may still be experiencing issues. If possible, we recommend retrieving up-to-date web site classification data from your security vendor, or specifically adding Limble to an allow list.
Posted Sep 15, 2026 - 12:30 MDT
Identified
We are seeing errors for some users accessing Limble through Microsoft Edge or on computers using Windows Defender. This may also be impacting users on local networks implementing network-based URL blocking.
The Limble application is currently operational, and we’ve verified that the application is safe and secure. We are working with a handful of third party security reputation services that have incorrectly marked the application as unsafe to update their classification.
Posted Sep 15, 2026 - 11:42 MDT
Update
This issue is affecting other parts of the Limble application (including login and task management) for some users. We are continuing to investigate.
Posted Sep 15, 2026 - 10:59 MDT
Investigating
We are currently investigating an issue that is causing errors on the Limble Work Request Portal when using the Microsoft Edge browser, or when using Microsoft Defender.
Posted Sep 15, 2026 - 10:31 MDT
This incident affects: Limble CMMS Web Application.