Intermittent application errors in EU region

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 12:03 MDT

Monitoring

We've identified the issue and have implemented a mitigation. We are currently monitoring to ensure the service is stable.
Posted Aug 18, 2026 - 10:38 MDT

Investigating

We are currently investigating reports of intermittent application loading errors in the Limble EU region.
Posted Aug 18, 2026 - 10:17 MDT
This incident affected: Limble CMMS Web Application.