Localized service degradation in Denver (Western US)
Incident Report for Limble
Resolved
This incident has been resolved.
Posted May 08, 2023 - 15:42 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 08, 2023 - 12:54 MDT
Investigating
We are currently investigating this issue.
Posted May 08, 2023 - 12:29 MDT
This incident affected: Limble CMMS Web Application and Limble CMMS API.