Customers are reporting issues with load times

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 16:33 MDT

Update

All functionality has been restored. We are continuing to monitor.
Posted Apr 29, 2025 - 16:17 MDT

Update

We are continuing to investigate and monitor issues with the following:
- Creating and managing assets
- Managing Vendors
- Purchase order management
- Some graph widgets are failing to load
Posted Apr 29, 2025 - 15:45 MDT

Update

A partial fix has been deployed. We are continuing to investigate issues with creating assets, reassigning tasks, and managing vendors.
Posted Apr 29, 2025 - 14:41 MDT

Monitoring

A partial fix has been deployed. We are continuing to investigate issues with creating assets and managing vendors.
Posted Apr 29, 2025 - 14:16 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2025 - 14:15 MDT

Investigating

We are currently investigating this issue.
Posted Apr 29, 2025 - 14:10 MDT
This incident affected: Limble CMMS Web Application.