Some customers reporting intermittent issues using the Limble application

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 12:45 MDT

Investigating

Some customers are intermittently experiencing slowness, errors, or pages failing to load on the Limble application
Posted Apr 28, 2025 - 12:20 MDT
This incident affected: Limble CMMS Web Application.