Tasks service performance issues

Incident Report for Limble

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 10:09 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 10:02 MDT

Investigating

We are currently investigating intermittent performance issues with a tasks-related service.
Posted Apr 07, 2026 - 09:52 MDT
This incident affected: Limble CMMS Web Application.