Emails not sending

Incident Report for Limble

Resolved

The backlog of emails has been sent, and new emails are flowing through the system.
Posted Sep 14, 2026 - 08:12 MDT

Update

New emails are being sent now. We are working through the backlog of previously triggered emails.
Posted Sep 14, 2026 - 07:36 MDT

Identified

We've identified the issue and are working on a fix.
Posted Sep 14, 2026 - 07:14 MDT

Investigating

We are currently investigating an issue that is preventing emails from being sent.
Posted Sep 14, 2026 - 07:03 MDT
This incident affected: Limble CMMS Web Application.