We are investigating reports of a small percentage of requests to the Limble application failing causing data to not load
Incident Report for Limble
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 21:06 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2022 - 16:27 MDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2022 - 11:41 MDT
This incident affected: Limble CMMS Web Application.