Users are unable to login to Limble Community and Limble Search

Incident Report for Limble

Resolved

A fix has been deployed to all regions, restoring Limble login access to Limble Community and Limble Search.
Posted Mar 09, 2026 - 14:16 MDT

Investigating

We are currently investigating and issue where users are unable to login to Limble Search and Limble Community sites with their Limble logins.
Posted Mar 09, 2026 - 13:45 MDT
This incident affected: Limble CMMS Authentication Service Backend and Limble Search.