PM creation failing in some regions

Incident Report for Limble

Resolved

This incident has been resolved. PM tasks are being created successfully.
Posted Feb 05, 2026 - 14:14 MST

Identified

We've identified an issue with PM tasks failing to be created in regions outside the US. We've implemented a fix and are monitoring the results.
Posted Feb 05, 2026 - 14:09 MST
This incident affected: Limble CMMS Web Application.