Loading Issues in Limble

Incident Report for Limble

Resolved

This incident has been resolved
Posted Apr 18, 2025 - 11:41 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 10:14 MDT

Identified

The issue has been identified and a fix is being applied
Posted Apr 18, 2025 - 10:01 MDT

Update

We are continuing to investigate this issue.
Posted Apr 18, 2025 - 09:58 MDT

Investigating

We are investigating reports of loading issues across the app, slow connections and white screens.
Posted Apr 18, 2025 - 09:15 MDT
This incident affected: Limble CMMS Web Application.